This article will help you understand the reason for the errors you may encounter during or after connecting Priceline/Agoda to Cloudbeds PMS and how to solve them.
If you can't find the problem you're facing in this list, reach out to our support. You can also reach out to your Priceline/Agoda Account Manager if you have questions about the Priceline/Agoda extranet.
Errors while connecting and updating the channel
Problem
While trying to create a listing with Priceline/Agoda, you get the following error message on Priceline/Agoda's extranet or in Cloudbeds PMS:
"An error occurred while creating this listing which may result in the failure to create one or more rate plans in Priceline/Agoda. Reach out to support@cloudbeds.com for assistance"
This is an error upcoming from the channel side, due to Priceline/Agoda limitations for Priceline/Agoda Homes supply (single unit properties) in some countries.
Solution:
Hotel-type properties (multi-unit) should be eligible. In case you can't connect this property type, reach out directly to Priceline/Agoda support team.
Problem
When trying to setup Priceline/Agoda, you receive this message:

Cause
This is caused when your Priceline/Agoda property ID is not associated with Cloudbeds channel manager as your channel manager. Priceline/Agoda must associate your property ID with Cloudbeds channel manager before it can be setup.
Solution
You must contact Priceline/Agoda to have your property ID associated with Cloudbeds channel manager - this can only be done by Priceline/Agoda and must be completed before you can setup Priceline/Agoda in our system.
Background
After an update attempt, the following error may appear for Priceline/Agoda:
Failed: 1114 Rates could not be updated: Some or all rates are above the maximum room rate set by the channel. As an example, please check [?roomname?] with rate [?ratename?], which should be below [?rate?]. To raise the maximum rate login into your Priceline/Agoda backoffice, go to Settings, Room Settings and raise the rates. (#FAULT.OTA.RATE.TOOHIGH.AGO)

Reasons and Solutions
Problem
There is a setting on Priceline/Agoda called Minimum Rate. It is set in order to prevent too low of prices being added by mistake or a third party.
If you have set a price on Cloudbeds PMS that is lower than the Minimum Rate set in Priceline/Agoda, the channel will respond with an error during the Full Refresh.
Solution
Go to your Priceline/Agoda's extranet and check the Minimum Rate for each room type.

You need to:
- Either make sure there are no base rates of all room types on Cloudbeds PMS that are lower than the Minimum Rate on Priceline/Agoda - and if you do, raise the room rates on Cloudbeds PMS. Follow the instructions here: How to Add / Edit Base Rates
- Or lower the Minimum Rate of your room types in Priceline/Agoda.
Reason
One of the rates on Cloudbeds PMS is too low.
Solution
Check your Availability Matrix on Cloudbeds PMS and make sure there are no rates that are too low (for example, you have set the room rate to 1 USD by mistake).
Follow instructions on how to update your base rates on Availability Matrix: Availability Matrix Overview
Problem
In very rare cases the error is caused by a mismatch in the currency between Cloudbeds PMS and Priceline/Agoda.
Solution
Make sure the currency on Cloudbeds PMS and inside Priceline/Agoda's extranet is the same.
Follow the instructions to set up the currency for your channels on Cloudbeds PMS: How to set up currency for channels
Background
The following error appears when performing full refresh:
"Please select a different rate plan for updates, as the currently selected rate plan is not enabled for updates."

Solution
According to this error code the Rate plan which failed is a child rate plan which is not allowed to set rate. Most likely this rate plan is linked to another master Rate plan so the system does not allow to set the rate of the child rate plan.
In case you would like to set the rate for each rate plan separately, you need to unlink the rate plan on YCS before sending the ARI update.
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